summary refs log tree commit diff
path: root/fuzz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'fuzz/Cargo.toml')
-rw-r--r--fuzz/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/fuzz/Cargo.toml b/fuzz/Cargo.toml
new file mode 100644
index 0000000..91c4bcb
--- /dev/null
+++ b/fuzz/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "crosvm-fuzz"
+version = "0.0.1"
+authors = ["Automatically generated"]
+publish = false
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies.kernel_loader]
+path = "../kernel_loader"
+[dependencies.libfuzzer-sys]
+git = "https://github.com/rust-fuzz/libfuzzer-sys.git"
+
+[dependencies]
+libc = "*"
+sys_util = { path = "../sys_util" }
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[[bin]]
+name = "fuzz_zimage"
+path = "fuzzers/fuzz_zimage.rs"