summary refs log tree commit diff
path: root/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2018-01-04 10:28:32 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-01-12 22:37:48 -0800
commit2b2a7d4d7667a974022a17b6a23d7bc00470be01 (patch)
treef31a898425eae69782f097bce3229f297ee773fc /fuzz/Cargo.toml
parentee2f1fe7708e1ec164c5da2483c26830e9c69373 (diff)
downloadcrosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar.gz
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar.bz2
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar.lz
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar.xz
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.tar.zst
crosvm-2b2a7d4d7667a974022a17b6a23d7bc00470be01.zip
Add kernel_loader fuzzing
Add a top level fuzz directory. Other fuzz tests will be added here in
subsequent commits.

For now fuzzing must be run manually. Soon there will be a way to
extract the fuzz artifacts and upload them to cluster fuzz.

Change-Id: Iddfb55af78af6f412927b2221f22acb882069d36
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/850851
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'fuzz/Cargo.toml')
-rw-r--r--fuzz/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/fuzz/Cargo.toml b/fuzz/Cargo.toml
new file mode 100644
index 0000000..91c4bcb
--- /dev/null
+++ b/fuzz/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "crosvm-fuzz"
+version = "0.0.1"
+authors = ["Automatically generated"]
+publish = false
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies.kernel_loader]
+path = "../kernel_loader"
+[dependencies.libfuzzer-sys]
+git = "https://github.com/rust-fuzz/libfuzzer-sys.git"
+
+[dependencies]
+libc = "*"
+sys_util = { path = "../sys_util" }
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[[bin]]
+name = "fuzz_zimage"
+path = "fuzzers/fuzz_zimage.rs"