summary refs log tree commit diff
path: root/release/combined/eosimages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release/combined/eosimages.nix')
-rw-r--r--release/combined/eosimages.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/release/combined/eosimages.nix b/release/combined/eosimages.nix
new file mode 100644
index 0000000..9f2ab10
--- /dev/null
+++ b/release/combined/eosimages.nix
@@ -0,0 +1,18 @@
+# SPDX-License-Identifier: MIT
+# SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
+
+{ config ? import ../../nix/eval-config.nix {} }: with config.pkgs;
+
+runCommand "eosimages.img" {
+  nativeBuildInputs = [ e2fsprogs tar2ext4 ];
+  imageName = "Spectrum-0.0-x86_64-generic.0.Live.img";
+  image = import ../live { inherit config; };
+} ''
+  mkdir dir
+  cd dir
+  ln -s $image Spectrum-0.0-x86_64-generic.0.Live.img
+  sha256sum $imageName > $imageName.sha256
+  tar -chf $NIX_BUILD_TOP/eosimages.tar *
+  tar2ext4 -i $NIX_BUILD_TOP/eosimages.tar -o $out
+  e2label $out eosimages
+''