summary refs log tree commit diff
path: root/release/checks/wayland/surface-notify/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'release/checks/wayland/surface-notify/meson.build')
-rw-r--r--release/checks/wayland/surface-notify/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/release/checks/wayland/surface-notify/meson.build b/release/checks/wayland/surface-notify/meson.build
new file mode 100644
index 0000000..624eef1
--- /dev/null
+++ b/release/checks/wayland/surface-notify/meson.build
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: EUPL-1.2+
+# SPDX-FileCopyrightText: 2023 Alyssa Ross <hi@alyssa.is>
+
+project('surface-notify', 'c', default_options : [ 'warning_level=2' ])
+
+libweston = dependency('libweston-12')
+wayland_server = dependency('wayland-server')
+
+shared_library('surface-notify', 'module.c',
+  name_prefix : '',
+  dependencies : [ libweston, wayland_server ],
+  install : true,
+  install_dir : get_option('libdir') / 'weston')