summary refs log tree commit diff
path: root/img/live/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'img/live/default.nix')
-rw-r--r--img/live/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/img/live/default.nix b/img/live/default.nix
index bebc1c1..770b03b 100644
--- a/img/live/default.nix
+++ b/img/live/default.nix
@@ -4,7 +4,7 @@
 { pkgs ? import <nixpkgs> {} }:
 
 let
-  inherit (pkgs.lib) cleanSource cleanSourceWith;
+  inherit (pkgs.lib) cleanSource cleanSourceWith hasSuffix;
 
   extfs = pkgs.pkgsStatic.callPackage ../../host/initramfs/extfs.nix {
     inherit pkgs;
@@ -20,7 +20,9 @@ stdenv.mkDerivation {
   name = "spectrum-live.img";
 
   src = cleanSourceWith {
-    filter = name: _type: name != "${toString ./.}/build";
+    filter = name: _type:
+      name != "${toString ./.}/build" &&
+      !(hasSuffix ".nix" name);
     src = cleanSource ./.;
   };