summary refs log tree commit diff
path: root/img/live/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'img/live/default.nix')
-rw-r--r--img/live/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/img/live/default.nix b/img/live/default.nix
index 5461384..1fa8da3 100644
--- a/img/live/default.nix
+++ b/img/live/default.nix
@@ -1,7 +1,11 @@
 # SPDX-License-Identifier: MIT
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
+# SPDX-FileCopyrightText: 2022 Unikie
 
-{ config ? import ../../nix/eval-config.nix {} }:
+{ config ? import ../../nix/eval-config.nix {} }: config.pkgs.callPackage (
+
+{ stdenvNoCC, cryptsetup, dosfstools, jq, mtools, util-linux, stdenv
+, systemd }:
 
 let
   inherit (config) pkgs;
@@ -15,8 +19,6 @@ let
   initramfs = import ../../host/initramfs { inherit config rootfs; };
 in
 
-with pkgs;
-
 stdenvNoCC.mkDerivation {
   name = "spectrum-live.img";
 
@@ -48,3 +50,4 @@ stdenvNoCC.mkDerivation {
 
   passthru = { inherit rootfs; };
 }
+) {}