summary refs log tree commit diff
path: root/img/combined/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'img/combined/default.nix')
-rw-r--r--img/combined/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/img/combined/default.nix b/img/combined/default.nix
index 86e07e2..16cd506 100644
--- a/img/combined/default.nix
+++ b/img/combined/default.nix
@@ -35,6 +35,16 @@ let
 
   grubCfg = substituteAll {
     src = ./grub.cfg.in;
+
+    nativeBuildInputs = [ mtools ];
+
+    preInstall = ''
+      export spectrumKernelParams="$(
+          mcopy -i ${eosimages.image}@@1M ::/loader/entries/spectrum.conf - |
+          grep '^options ' |
+          sed 's/^options //')"
+    '';
+
     linux = removePrefix storeDir installer.kernel;
     initrd = removePrefix storeDir installer.initramfs;
     inherit (installer) kernelParams;