summary refs log tree commit diff
path: root/host/start-vm/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/start-vm/default.nix')
-rw-r--r--host/start-vm/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/host/start-vm/default.nix b/host/start-vm/default.nix
index ac31022..56be882 100644
--- a/host/start-vm/default.nix
+++ b/host/start-vm/default.nix
@@ -5,13 +5,16 @@
 { lib, stdenv, fetchpatch, meson, ninja, rustc }:
 
 let
-  inherit (lib) cleanSource;
+  inherit (lib) cleanSource cleanSourceWith hasSuffix;
 in
 
 stdenv.mkDerivation {
   name = "start-vm";
 
-  src = cleanSource ./.;
+  src = cleanSourceWith {
+    filter = name: _type: !(hasSuffix ".nix" name);
+    src = cleanSource ./.;
+  };
 
   nativeBuildInputs = [ meson ninja rustc ];