summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index 7ac3d3a..d4c96d9 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -9,7 +9,7 @@
 }:
 
 let
-  inherit (lib) cleanSource cleanSourceWith concatMapStringsSep;
+  inherit (lib) cleanSource cleanSourceWith concatMapStringsSep hasSuffix;
 
   start-vm = import ../start-vm { pkgs = pkgs.pkgsStatic; };
 
@@ -83,7 +83,8 @@ stdenv.mkDerivation {
   name = "spectrum-rootfs";
 
   src = cleanSourceWith {
-    filter = name: _type: name != "${toString ./.}/build";
+    filter = name: _type:
+      name != "${toString ./.}/build" && !(hasSuffix ".nix" name);
     src = cleanSource ./.;
   };