summary refs log tree commit diff
path: root/host/initramfs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/initramfs/shell.nix')
-rw-r--r--host/initramfs/shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/initramfs/shell.nix b/host/initramfs/shell.nix
index 48c1f81..5475737 100644
--- a/host/initramfs/shell.nix
+++ b/host/initramfs/shell.nix
@@ -1,7 +1,7 @@
 # SPDX-License-Identifier: MIT
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
 
-{ config ? import ../../nix/eval-config.nix {} }:
+import ../../nix/eval-config.nix ({ config, ... } @ args:
 
 let
   inherit (config) pkgs;
@@ -23,4 +23,4 @@ initramfs.overrideAttrs ({ nativeBuildInputs ? [], ... }: {
   EXT_FS = extfs;
   KERNEL = "${rootfs.kernel}/${stdenv.hostPlatform.linux-kernel.target}";
   ROOT_FS = rootfs;
-})
+}))