summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2021-11-18 10:17:35 +0000
committerAlyssa Ross <hi@alyssa.is>2021-11-19 19:58:06 +0000
commit58250047c995d5e0fd671d6e99aeefecff9dc7eb (patch)
tree0a66df05e5b2a602b9f05b87a885c448be920efa /shell.nix
parentc70f884caa5dece1577843a35e85705dcd326d98 (diff)
downloadspectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar.gz
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar.bz2
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar.lz
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar.xz
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.tar.zst
spectrum-58250047c995d5e0fd671d6e99aeefecff9dc7eb.zip
Makefile: add Cloud Hypervisor testing support
This is a bit more annoying to use because it requires a privileged
user to have set up some tap devices, but it's useful for testing
virtio-console.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index ffad1fa..0b5ed2b 100644
--- a/shell.nix
+++ b/shell.nix
@@ -9,7 +9,9 @@ with pkgs;
 { passthru ? {}, nativeBuildInputs ? [], ... }:
 
 {
-  nativeBuildInputs = nativeBuildInputs ++ [ qemu_kvm reuse ];
+  nativeBuildInputs = nativeBuildInputs ++ [
+    cloud-hypervisor jq qemu_kvm reuse
+  ];
 
   KERNEL = "${passthru.kernel.dev}/vmlinux";
 })