summary refs log tree commit diff
path: root/release/checks/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-05-26 22:15:42 +0000
committerAlyssa Ross <hi@alyssa.is>2023-05-27 21:44:43 +0000
commit59546e9055a3efdc67ec21a6edd7a22769b3b107 (patch)
tree3c7ba687e4ac17ed1387aba6cc23953e481c3eb8 /release/checks/default.nix
parent6b34ec8a8ba7c48837edcec06be808d773ce793a (diff)
downloadspectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar.gz
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar.bz2
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar.lz
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar.xz
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.tar.zst
spectrum-59546e9055a3efdc67ec21a6edd7a22769b3b107.zip
host/initramfs: panic if roothash is missing
We're not going to be able to boot if we don't know what roothash
we're looking for, so abort the boot at that point rather than hanging
forever.

This should never happen on an actual system, but it makes things
clearer in testing if something has gone wrong with the kernel command
line.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'release/checks/default.nix')
-rw-r--r--release/checks/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/release/checks/default.nix b/release/checks/default.nix
index bf26b9a..bae9159 100644
--- a/release/checks/default.nix
+++ b/release/checks/default.nix
@@ -10,6 +10,8 @@ import ../../lib/eval-config.nix ({ ... } @ args:
 
   pkg-tests = import ./pkg-tests.nix args;
 
+  no-roothash = import ./no-roothash.nix args;
+
   reuse = import ./reuse.nix args;
 
   rustfmt = import ./rustfmt.nix args;