summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-06-08 09:42:16 +0000
committerAlyssa Ross <hi@alyssa.is>2022-08-12 08:42:25 +0000
commit9dad8a2845030a810cfbd5ba116141df105e9624 (patch)
treeacb7fe960aea741bf910950474206af66a7f39f0 /release.nix
parentb8f6f85eab297f614bcf2f2fed2045905182de8b (diff)
downloadspectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar.gz
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar.bz2
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar.lz
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar.xz
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.tar.zst
spectrum-9dad8a2845030a810cfbd5ba116141df105e9624.zip
release.nix: add to populate binary cache
Previously, the binary cache just built img/combined, which was not
very obvious or extensible.  I'd like to have it build development
shells, as well as possibly replacement bootstrap tools for
aarch64-unknown-linux-musl until we can get them updated upstream.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/release.nix b/release.nix
new file mode 100644
index 0000000..ab753ac
--- /dev/null
+++ b/release.nix
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: MIT
+# SPDX-FileCopyrightText: 2022 Alyssa Ross <hi@alyssa.is>
+
+# This file is built to populate the binary cache.
+
+{ pkgs ? import <nixpkgs> {} }:
+
+{
+  combined = import img/combined/run-vm.nix { inherit pkgs; };
+}