summary refs log tree commit diff
path: root/img/app/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-11-22 19:35:20 +0100
committerAlyssa Ross <hi@alyssa.is>2023-11-22 21:49:24 +0100
commit1af0080f06f746f263204b6e659fa918427c70d2 (patch)
tree3068013c243b250659ad7f552ffae3455cd1ec7f /img/app/default.nix
parentdb6a8b1dc29f48ae5b2c53d3d04cf0043ee50ea7 (diff)
downloadspectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar.gz
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar.bz2
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar.lz
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar.xz
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.tar.zst
spectrum-1af0080f06f746f263204b6e659fa918427c70d2.zip
vm: use linux from pkgsStatic
I think the original reason for not using the pkgsStatic version of
the kernel was just that it was built by cache.nixos.org.  Now that
we're using a custom configuration, it wouldn't be cached anyway, so
let's not special case the kernel any more.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'img/app/default.nix')
-rw-r--r--img/app/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/img/app/default.nix b/img/app/default.nix
index aecab17..11600da 100644
--- a/img/app/default.nix
+++ b/img/app/default.nix
@@ -13,7 +13,7 @@ config.pkgs.pkgsStatic.callPackage (
 
 { lib, stdenvNoCC, runCommand, writeReferencesToFile
 , erofs-utils, jq, s6-rc, util-linux
-, busybox, cacert, execline, kmod, mdevd, s6, s6-linux-init
+, busybox, cacert, execline, kmod, linux_latest, mdevd, s6, s6-linux-init
 }:
 
 let
@@ -57,7 +57,7 @@ let
     else
       stdenvNoCC.hostPlatform.linux-kernel.target;
 
-  kernel = (config.pkgs.linux_latest.override {
+  kernel = (linux_latest.override {
     structuredExtraConfig = with lib.kernel; {
       CMDLINE_BOOL = yes;
       CMDLINE = freeform "console=ttyS0 root=PARTLABEL=root";