summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-08-02 13:25:45 +0000
committerAlyssa Ross <hi@alyssa.is>2023-08-02 13:29:03 +0000
commitfcb434e4a33b12c8c923f4eed45c6b6192953c3e (patch)
tree9de9722976dee6d676995468a25d051fc33d7e6a /host/rootfs/default.nix
parent61d0dc306cc7eadd14388c7a1a23f49feb62376c (diff)
downloadspectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar.gz
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar.bz2
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar.lz
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar.xz
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.tar.zst
spectrum-fcb434e4a33b12c8c923f4eed45c6b6192953c3e.zip
host/rootfs: usr lib merge
There's no real reason for /usr/lib and /lib to be separate locations,
and it's atypical nowadays.  Not done for VMs because they don't have
/usr/lib at all so far.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index b0fe4d7..0ebea67 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -90,20 +90,20 @@ let
 
   # Packages that should be fully linked into /usr,
   # (not just their bin/* files).
-  usrPackages = [ appvm pkgsGui.mesa.drivers pkgsGui.dejavu_fonts ];
+  usrPackages = [
+    appvm kernel firmware pkgsGui.mesa.drivers pkgsGui.dejavu_fonts
+  ];
 
   packagesSysroot = runCommand "packages-sysroot" {
     nativeBuildInputs = [ xorg.lndir ];
   } ''
-    mkdir -p $out/lib $out/usr/bin
+    mkdir -p $out/usr/bin
     ln -s ${concatMapStringsSep " " (p: "${p}/bin/*") packages} $out/usr/bin
 
     for pkg in ${lib.escapeShellArgs usrPackages}; do
         lndir -silent "$pkg" "$out/usr"
     done
 
-    ln -s ${kernel}/lib/modules ${firmware}/lib/firmware $out/lib
-
     # TODO: this is a hack and we should just build the util-linux
     # programs we want.
     # https://lore.kernel.org/util-linux/87zgrl6ufb.fsf@alyssa.is/