summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-08-09 11:09:20 +0000
committerAlyssa Ross <hi@alyssa.is>2022-08-12 09:58:21 +0000
commitb01594b2c089ce2434dacddccf9a285af7334d24 (patch)
tree3022cec847195497cd2383450bd5872a8f9d89b7 /host/rootfs/default.nix
parent916a199594ba222ff5bf062812b6c6776791093b (diff)
downloadspectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar.gz
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar.bz2
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar.lz
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar.xz
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.tar.zst
spectrum-b01594b2c089ce2434dacddccf9a285af7334d24.zip
host/rootfs: disable systemd in weston deps
We're overriding the systemd attribute to point to libudev-zero, so
anything that's trying to build with special systemd support isn't
going to work.  We wouldn't be using that anyway, so just overlay
those packages to disable systemd support.

Long term, we can try to fix this upstream by separating the "udev"
and "systemd" attributes, and only overriding the udev one.  But that
would be quite a bit of work, and making this change here allows us to
drop a bunch of Nixpkgs patches to disable weston dependencies, so
this is still progress.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index a9d52ee..e5f316f 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -1,5 +1,6 @@
 # SPDX-License-Identifier: MIT
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
+# SPDX-FileCopyrightText: 2022 Unikie
 
 { pkgs ? import <nixpkgs> {} }: pkgs.pkgsStatic.callPackage (
 
@@ -16,6 +17,20 @@ let
 
   pkgsGui = pkgs.pkgsMusl.extend (final: super: {
     systemd = final.libudev-zero;
+
+    colord = super.colord.overrideAttrs ({ mesonFlags ? [], ... }: {
+      mesonFlags = mesonFlags ++ [
+        "-Dsystemd=false"
+        "-Dudev_rules=false"
+      ];
+    });
+
+    weston = super.weston.overrideAttrs ({ mesonFlags ? [], ... }: {
+      mesonFlags = mesonFlags ++ [
+        "-Dlauncher-logind=false"
+        "-Dsystemd=false"
+      ];
+    });
   });
 
   foot = pkgsGui.foot.override { allowPgo = false; };