summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2023-09-23 15:55:48 +0000
committerAlyssa Ross <hi@alyssa.is>2023-09-23 15:55:48 +0000
commit94ddba21a2221b2e8bc80c0b1cbbc904abc302b7 (patch)
tree3e993489596f2f728186427a474617ff9a7253db /host/rootfs/default.nix
parent7a8c61dedcdfa61285f1d28e71332c72dd011614 (diff)
downloadspectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar.gz
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar.bz2
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar.lz
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar.xz
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.tar.zst
spectrum-94ddba21a2221b2e8bc80c0b1cbbc904abc302b7.zip
host/rootfs: fix DejaVuSans.ttf link
This was a broken symlink without -ignorelinks.  Adding the flag fixes
it, and the changes to all other links look fine.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index c735444..1bff907 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -106,7 +106,7 @@ let
     ln -s ${concatMapStringsSep " " (p: "${p}/bin/*") packages} $out/usr/bin
 
     for pkg in ${lib.escapeShellArgs usrPackages}; do
-        lndir -silent "$pkg" "$out/usr"
+        lndir -ignorelinks -silent "$pkg" "$out/usr"
     done
 
     # TODO: this is a hack and we should just build the util-linux