summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <alyssa.ross@unikie.com>2022-09-19 08:30:27 +0000
committerAlyssa Ross <alyssa.ross@unikie.com>2022-09-23 12:36:24 +0000
commit4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6 (patch)
tree3231974c2c91c66e4580fd96beef04c4aadbba51 /host/rootfs/default.nix
parent0ca216d4ff06caa2ff6416e247c68f1e968d14d4 (diff)
downloadspectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar.gz
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar.bz2
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar.lz
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar.xz
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.tar.zst
spectrum-4a5e2760c4bdb337e6b7b5cbe0a0c9e3cc62c7f6.zip
host/rootfs: override systemdMinimal in pkgsGui
In an upcoming Nixpkgs update, some packages in Weston's closure will
have changed to use systemdMinimal, so we have to override that too.
As a side-effect, we have to disable systemd support in polkit, or it
will fail to build due to the new override.

Signed-off-by: Alyssa Ross <alyssa.ross@unikie.com>
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index 874de78..56d6ec0 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -20,6 +20,7 @@ let
 
   pkgsGui = pkgs.pkgsMusl.extend (final: super: {
     systemd = final.libudev-zero;
+    systemdMinimal = final.libudev-zero;
 
     colord = super.colord.overrideAttrs ({ mesonFlags ? [], ... }: {
       mesonFlags = mesonFlags ++ [
@@ -28,6 +29,10 @@ let
       ];
     });
 
+    polkit = super.polkit.override {
+      useSystemd = false;
+    };
+
     weston = super.weston.overrideAttrs ({ mesonFlags ? [], ... }: {
       mesonFlags = mesonFlags ++ [
         "-Dlauncher-logind=false"