summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-09-01 10:46:29 +0000
committerAlyssa Ross <hi@alyssa.is>2022-09-08 11:58:53 +0000
commit44d289986b1ef4d7a0c6655b97a487fb61b45534 (patch)
treefeb6b130c7eeb783b32d783311b270fa503a6b98 /host/rootfs/default.nix
parent6af16d04b71fd4a675e77dd707bc8e36513c8a85 (diff)
downloadspectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar.gz
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar.bz2
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar.lz
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar.xz
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.tar.zst
spectrum-44d289986b1ef4d7a0c6655b97a487fb61b45534.zip
host/rootfs: remove kernel override
These drivers should be loaded by the initramfs if required — most
Spectrum installs won't need the virtio drivers on the host, and
overriding the kernel means more stuff we can't reuse from
cache.nixos.org.

We'll probably want to build in the driver for whatever filesystem we
end up using for the root file system eventually, since it will always
be required, but that should be done as part of a more systematic
effort to optimise our kernel configuration.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Message-Id: <20220901104629.863380-2-hi@alyssa.is>
Tested-by: José Pekkarinen <jose.pekkarinen@unikie.com>
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index e5f316f..a651a20 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -65,14 +65,7 @@ let
     imports = [ (modulesPath + "/profiles/all-hardware.nix") ];
   });
 
-  kernel = pkgs.linux_latest.override {
-    structuredExtraConfig = with lib.kernel; {
-      VIRTIO = yes;
-      VIRTIO_PCI = yes;
-      VIRTIO_BLK = yes;
-      EXT4_FS = yes;
-    };
-  };
+  kernel = pkgs.linux_latest;
 
   packagesSysroot = runCommand "packages-sysroot" {
     nativeBuildInputs = [ xorg.lndir ];