summary refs log tree commit diff
path: root/host/initramfs/extfs.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-10-10 23:28:49 +0000
committerAlyssa Ross <hi@alyssa.is>2023-02-26 19:12:48 +0000
commit3ed22c6d4940b09d90e12b7b7934b55d06da0b7f (patch)
treea7f8462c5b4eed98d75f2b75f91cadfabef9204a /host/initramfs/extfs.nix
parent933e91a25275d293439368c7c408de48e8f7d8af (diff)
downloadspectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar.gz
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar.bz2
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar.lz
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar.xz
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.tar.zst
spectrum-3ed22c6d4940b09d90e12b7b7934b55d06da0b7f.zip
vm/app/mg.nix: init
mg is a text editor with a built-in filesystem browser, so it will be
useful for testing virtiofs.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Message-Id: <20221010232909.1953738-10-hi@alyssa.is>
Diffstat (limited to 'host/initramfs/extfs.nix')
-rw-r--r--host/initramfs/extfs.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/host/initramfs/extfs.nix b/host/initramfs/extfs.nix
index 5c5850f..66be95c 100644
--- a/host/initramfs/extfs.nix
+++ b/host/initramfs/extfs.nix
@@ -11,12 +11,13 @@ let
 
   appvm-catgirl = import ../../vm/app/catgirl.nix { inherit config; };
   appvm-lynx = import ../../vm/app/lynx.nix { inherit config; };
+  appvm-mg = import ../../vm/app/mg.nix { inherit config; };
 in
 
 runCommand "ext.ext4" {
   nativeBuildInputs = [ e2fsprogs ];
 } ''
-  mkdir -p root/svc/data/appvm-{catgirl,lynx}
+  mkdir -p root/svc/data/appvm-{catgirl,lynx,mg}
   cd root
 
   tar -C ${netvm} -c data | tar -C svc -x
@@ -24,6 +25,7 @@ runCommand "ext.ext4" {
 
   tar -C ${appvm-catgirl} -c . | tar -C svc/data/appvm-catgirl -x
   tar -C ${appvm-lynx} -c . | tar -C svc/data/appvm-lynx -x
+  tar -C ${appvm-mg} -c . | tar -C svc/data/appvm-mg -x
 
   mkfs.ext4 -d . $out 16T
   resize2fs -M $out