summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2021-11-15 22:50:00 +0000
committerAlyssa Ross <hi@alyssa.is>2021-11-26 15:18:41 +0000
commitd562141e47e4d802190d7300383de44a1e03044b (patch)
tree25621ea67e8a95a8b8fa91f021861cf2da2bb644 /default.nix
parent2e795f9688c80093ab962020d29c35a51c7f0708 (diff)
downloadspectrum-d562141e47e4d802190d7300383de44a1e03044b.tar
spectrum-d562141e47e4d802190d7300383de44a1e03044b.tar.gz
spectrum-d562141e47e4d802190d7300383de44a1e03044b.tar.bz2
spectrum-d562141e47e4d802190d7300383de44a1e03044b.tar.lz
spectrum-d562141e47e4d802190d7300383de44a1e03044b.tar.xz
spectrum-d562141e47e4d802190d7300383de44a1e03044b.tar.zst
spectrum-d562141e47e4d802190d7300383de44a1e03044b.zip
default.nix: /bin -> /usr/bin
We're going to need files other than binaries (e.g. mesa libraries),
so it's nicer to have these all under one directory than all over the
root.

We leave kernel modules as an exception for now because that's the
convention.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index db8c81a..81d0abc 100644
--- a/default.nix
+++ b/default.nix
@@ -31,15 +31,14 @@ let
   };
 
   packagesSysroot = runCommand "packages-sysroot" {} ''
-    mkdir -p $out/bin
-    ln -s ${concatMapStringsSep " " (p: "${p}/bin/*") packages} $out/bin
-    ln -s bin $out/sbin
+    mkdir -p $out/usr/bin
+    ln -s ${concatMapStringsSep " " (p: "${p}/bin/*") packages} $out/usr/bin
     ln -s ${kernel}/lib $out/lib
 
     # TODO: this is a hack and we should just build the util-linux
     # programs we want.
     # https://lore.kernel.org/util-linux/87zgrl6ufb.fsf@alyssa.is/
-    ln -s ${util-linux.override { systemd = null; }}/bin/lsblk $out/bin
+    ln -s ${util-linux.override { systemd = null; }}/bin/lsblk $out/usr/bin
   '';
 
   packagesTar = runCommand "packages.tar" {} ''