summary refs log tree commit diff
path: root/Documentation/jekyll.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-08-12 08:32:49 +0000
committerAlyssa Ross <hi@alyssa.is>2022-08-12 08:34:46 +0000
commitc937449c8c42b6825d134b5846326a16703e5a6b (patch)
treea9e5f4f6c6ed8406434362349276d02f007ac920 /Documentation/jekyll.nix
parent74003c57ab0adf65d6c88b274f3215179c405ffd (diff)
downloadspectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar.gz
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar.bz2
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar.lz
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar.xz
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.tar.zst
spectrum-c937449c8c42b6825d134b5846326a16703e5a6b.zip
Documentation: update just-the-docs to 0.4.0.rc1
This allows us to drop all our patches, which have now been applied
upstream.

Signed-off-by: Alyssa Ross <hi@alyssa.is>
Diffstat (limited to 'Documentation/jekyll.nix')
-rw-r--r--Documentation/jekyll.nix37
1 files changed, 1 insertions, 36 deletions
diff --git a/Documentation/jekyll.nix b/Documentation/jekyll.nix
index 1aa8524..bc804b1 100644
--- a/Documentation/jekyll.nix
+++ b/Documentation/jekyll.nix
@@ -3,46 +3,11 @@
 
 { pkgs ? import <nixpkgs> {} }: pkgs.callPackage (
 
-{ lib, bundlerApp, defaultGemConfig, fetchFromGitHub, fetchpatch }:
+{ bundlerApp }:
 
 bundlerApp {
   pname = "jekyll";
   gemdir = ./.;
   exes = [ "jekyll" ];
-
-  gemConfig = defaultGemConfig // {
-    # We override Just the Docs to improve AsciiDoc support.
-    just-the-docs = attrs:
-      let super = defaultGemConfig.just-the-docs or (lib.const {}) attrs; in
-      super // {
-        # The gem tarball doesn't contain e.g. the SCSS files.
-        src = fetchFromGitHub {
-          owner = "just-the-docs";
-          repo = "just-the-docs";
-          rev = assert attrs.version == "0.3.3"; "8bc53f8f45ce6a11be0559c764d39d90f2434ec1";
-          sha256 = "sha256-pvct9Ob/TzTZvj2YVZ36FtU2Uo465p3aUc0NCd/0oWo=";
-        };
-
-        patches = super.patches or attrs.patches or [] ++ [
-          (fetchpatch {
-            url = "https://github.com/just-the-docs/just-the-docs/compare/3a834d24ab1bda72f481f1e630f28fb9ba78ce64...7627fdb73decc0dd9264729a4ac302065c81bf24.patch";
-            sha256 = "sha256-5jWAlNvkCPu/U4aTrzal8GxoWmcSSKiKAwzu5pjCrPE=";
-          })
-
-          # Don't use domains in links, which would require different
-          # configuration when running locally vs on the website.
-          # https://github.com/just-the-docs/just-the-docs/pull/544
-          (fetchpatch {
-            url = "https://github.com/just-the-docs/just-the-docs/commit/7bb40aa3c71d989339322ad946cfdd8287717a94.patch";
-            sha256 = "sha256-3e6N1B9lAgSYVRMLLvhsfOP5CXuespKJk/pyGdbK4wg=";
-          })
-        ];
-
-        postPatch = ''
-          substituteInPlace just-the-docs.gemspec \
-              --replace 'git ls-files -z' 'find * -print0'
-        '';
-      };
-  };
 }
 ) { }