summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..6b05783
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,20 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+  name = "spectrum-doc";
+
+  src = builtins.fetchGit ./.;
+
+  nativeBuildInputs = [ asciidoctor ];
+
+  installPhase = ''
+    mkdir -p $out/share/doc/spectrum
+    mv developer-manual.html $out/share/doc/spectrum
+  '';
+
+  meta = with lib; {
+    homepage = "https://spectrum-os.org/doc/";
+    maintainers = with maintainers; [ qyliss ];
+    licenses = with licenses; [ fdl13Plus /* or */ cc-by-sa-40 ];
+  };
+}