summary refs log tree commit diff
path: root/x86_64/Cargo.toml
diff options
context:
space:
mode:
authorSonny Rao <sonnyrao@chromium.org>2018-02-01 15:52:58 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-03-02 22:22:29 -0800
commit43724a239b057e48eefd29489c57fd08cdfa8b8f (patch)
tree13313214f2a0dc0726a769cfb7268a98788e7f07 /x86_64/Cargo.toml
parent0a404b8a0ea52344024e61c4631a328d49af9a1e (diff)
downloadcrosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar.gz
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar.bz2
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar.lz
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar.xz
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.tar.zst
crosvm-43724a239b057e48eefd29489c57fd08cdfa8b8f.zip
crosvm: move x86_64 arch specific stuff into the x86_64 crate
This is in preparation to make different architectures implement a
trait, but for now it's just moving code out of linux.rs and into
x86_64 trait.  A few new functions were required which will become
part of the trait interface.  There's still a lot of ugly ifdefs
everywhere that should go away in subsequent CLs.

BUG=chromium:797868
TEST=./build_test
TEST=run crosvm on caroline

Change-Id: Ifc95d4eb84f64ebacb4481a172524d94dc96b7bb
Signed-off-by: Sonny Rao <sonnyrao@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/942084
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'x86_64/Cargo.toml')
-rw-r--r--x86_64/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/x86_64/Cargo.toml b/x86_64/Cargo.toml
index 85ff1b7..edad6b6 100644
--- a/x86_64/Cargo.toml
+++ b/x86_64/Cargo.toml
@@ -5,8 +5,12 @@ authors = ["The Chromium OS Authors"]
 
 [dependencies]
 data_model = { path = "../data_model" }
+devices = { path = "../devices" }
+device_manager = { path = "../device_manager" }
 kvm_sys = { path = "../kvm_sys" }
 kvm = { path = "../kvm" }
 sys_util = { path = "../sys_util" }
+kernel_cmdline = { path = "../kernel_cmdline" }
+kernel_loader = { path = "../kernel_loader" }
 libc = "*"
 byteorder = "*"