summary refs log tree commit diff
path: root/vm_control/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2017-10-06 15:30:34 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-10-09 17:39:04 -0700
commit94bf1bf6b4a7791757937e2ffb2a81e797b82922 (patch)
tree386430a70c5fe176d8ae981aa1ca9b5bfc2d346f /vm_control/Cargo.toml
parentd0c9adc642fc968cb347952eed1d7fd0d0a8e80e (diff)
downloadcrosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.gz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.bz2
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.lz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.xz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.zst
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.zip
Move vm_control to a top-level crate
Break out vm_control to a crate that will be able to used by more
modules. Having vm_control usable from outside crosvm makes it possible
to move the devices out of crosvm in a later commit.

Change-Id: I1f060700ed49b5d77519d55efa2430490d521256
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/706558
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'vm_control/Cargo.toml')
-rw-r--r--vm_control/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/vm_control/Cargo.toml b/vm_control/Cargo.toml
new file mode 100644
index 0000000..06b3695
--- /dev/null
+++ b/vm_control/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "vm_control"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[dependencies]
+data_model = { path = "../data_model" }
+kvm = { path = "../kvm" }
+libc = "*"
+sys_util = { path = "../sys_util" }