summary refs log tree commit diff
path: root/tempfile/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Verkamp <dverkamp@chromium.org>2019-06-13 19:36:08 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-07-03 16:35:43 -0700
commitda52468b34ceacf8a3d74d191f09cf9d8099a0a6 (patch)
tree2b8f1afbd160ffdacfc2c085565b05e2fa235a49 /tempfile/Cargo.toml
parent5104b9641cc6e85adcf45bebe636228ae6ab6eee (diff)
downloadcrosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar.gz
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar.bz2
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar.lz
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar.xz
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.tar.zst
crosvm-da52468b34ceacf8a3d74d191f09cf9d8099a0a6.zip
tempfile: reimplement using libc::mkdtemp
POSIX provides a standard mkdtemp() function to securely create a
temporary directory; use it rather than reinventing the wheel.

This also drops the dependency of tempfile on rand_ish, which will allow
easier use of the tempfile implementation outside of crosvm.

BUG=chromium:974059
TEST=cargo test -p tempfile

Change-Id: I34a226b046dc6f272106988a78d121a24a377f44
Signed-off-by: Daniel Verkamp <dverkamp@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/1659971
Tested-by: kokoro <noreply+kokoro@google.com>
Legacy-Commit-Queue: Commit Bot <commit-bot@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'tempfile/Cargo.toml')
-rw-r--r--tempfile/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/tempfile/Cargo.toml b/tempfile/Cargo.toml
index b12e976..b7ac1c1 100644
--- a/tempfile/Cargo.toml
+++ b/tempfile/Cargo.toml
@@ -5,4 +5,4 @@ authors = ["The Chromium OS Authors"]
 edition = "2018"
 
 [dependencies]
-rand_ish = { path = "../rand_ish" }
+libc = "*"