summary refs log tree commit diff
path: root/sys_util/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-03-12 20:52:34 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-08 22:30:35 -0700
commitce48c2b98676dd459fbae0fab88d8beb4b07d8b2 (patch)
treedab9b2d37e1d6b319f93394c234c992e7d725d0d /sys_util/Cargo.toml
parent939997566d931042580f6ac173747059d222604b (diff)
downloadcrosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar.gz
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar.bz2
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar.lz
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar.xz
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.tar.zst
crosvm-ce48c2b98676dd459fbae0fab88d8beb4b07d8b2.zip
edition: Update sys_util to 2018 edition
Separated out of CL:1513058 to make it possible to land parts
individually while the affected crate has no other significant CLs
pending. This avoids repeatedly introducing non-textual conflicts with
new code that adds `use` statements.

TEST=cargo check
TEST=cargo check --all-features
TEST=cargo check --target aarch64-unknown-linux-gnu

Change-Id: Ic57170776a9396bab54a8c7eb2b8b1436f63b57c
Reviewed-on: https://chromium-review.googlesource.com/1520069
Commit-Ready: David Tolnay <dtolnay@chromium.org>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: David Tolnay <dtolnay@chromium.org>
Diffstat (limited to 'sys_util/Cargo.toml')
-rw-r--r--sys_util/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/sys_util/Cargo.toml b/sys_util/Cargo.toml
index 5dd67f2..e9fcfd7 100644
--- a/sys_util/Cargo.toml
+++ b/sys_util/Cargo.toml
@@ -2,6 +2,7 @@
 name = "sys_util"
 version = "0.1.0"
 authors = ["The Chromium OS Authors"]
+edition = "2018"
 include = ["src/**/*", "Cargo.toml"]
 
 [dependencies]