summary refs log tree commit diff
path: root/sys_util/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2017-07-06 17:59:49 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-07-20 21:21:29 -0700
commitbf36bcbc4a843279aebff26666a5ca802a7b37fb (patch)
tree45e55132950ca29c48945723c91c80ed0fba4fe4 /sys_util/Cargo.toml
parent3a4cca14a0a840971410b6e7dd3e1871939d0f03 (diff)
downloadcrosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar.gz
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar.bz2
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar.lz
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar.xz
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.tar.zst
crosvm-bf36bcbc4a843279aebff26666a5ca802a7b37fb.zip
sys_util: add sock_ctrl_msg module for transmitting messages with FD
This CL also includes the gcc build time dependency for building the
sock_ctrl_msg.c helper code.

TEST=cargo test
BUG=chromium:738638

Change-Id: I4adc2360b7fab4ed7d557603aa7bad2e738b69b4
Reviewed-on: https://chromium-review.googlesource.com/562574
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Chirantan Ekbote <chirantan@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'sys_util/Cargo.toml')
-rw-r--r--sys_util/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys_util/Cargo.toml b/sys_util/Cargo.toml
index df54b13..bc9e1f9 100644
--- a/sys_util/Cargo.toml
+++ b/sys_util/Cargo.toml
@@ -2,8 +2,12 @@
 name = "sys_util"
 version = "0.1.0"
 authors = ["The Chromium OS Authors"]
+build = "build.rs"
 
 [dependencies]
 data_model = { path = "../data_model" }
 libc = "*"
-syscall_defines = { path = "../syscall_defines" }
\ No newline at end of file
+syscall_defines = { path = "../syscall_defines" }
+
+[build-dependencies]
+gcc = "0.3"