summary refs log tree commit diff
path: root/net_util/Cargo.toml
diff options
context:
space:
mode:
authorStephen Barber <smbarber@chromium.org>2017-06-15 23:21:15 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-07-13 22:03:30 -0700
commit253ac89d919b6d926c770e90a604ba0439ef646b (patch)
treeed5e607201cedf7ce2387fa012b9b26c970949b9 /net_util/Cargo.toml
parent219b1856eb41c8c6a0dfefb4d8d257afe70886f9 (diff)
downloadcrosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar.gz
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar.bz2
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar.lz
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar.xz
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.tar.zst
crosvm-253ac89d919b6d926c770e90a604ba0439ef646b.zip
net_util: add crate for creating/configuring tap interfaces
Signed-off-by: Stephen Barber <smbarber@chromium.org>

BUG=chromium:738639
TEST=cargo test

Change-Id: Iddf715d40164abeeb6923e8e5a84c02233e0ab64
Reviewed-on: https://chromium-review.googlesource.com/538103
Commit-Ready: Stephen Barber <smbarber@chromium.org>
Tested-by: Stephen Barber <smbarber@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'net_util/Cargo.toml')
-rw-r--r--net_util/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/net_util/Cargo.toml b/net_util/Cargo.toml
new file mode 100644
index 0000000..1bcf18c
--- /dev/null
+++ b/net_util/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "net_util"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[dependencies]
+libc = "*"
+net_sys = { path = "../net_sys" }
+sys_util = { path = "../sys_util" }