summary refs log tree commit diff
path: root/kvm/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2017-05-03 18:11:39 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-05-08 12:40:51 -0700
commit66b86b50cad0ee726194bee54c60bfbb7abb4fbe (patch)
treea0e96663e2e7ba837d2a137b42321f9fb0c0a064 /kvm/Cargo.toml
parent48faad1bc60c818cd472ac43389e44e4446ff020 (diff)
downloadcrosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar.gz
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar.bz2
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar.lz
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar.xz
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.tar.zst
crosvm-66b86b50cad0ee726194bee54c60bfbb7abb4fbe.zip
kvm: add kvm crate to safely use kvm
This change adds a library that makes the usage of kvm safe. Features
that are in this initial patch are:
- checking for kvm extensions
- creating vms and vcpus
- adding memory regions
- accessing cpu registers
- running vcpus
- using kvm_run structure on kvm exit
- registering ioevents and irqevents

TEST=cargo test [--target=armv7a-cros-linux-gnueabi]
BUG=chromium:711556

Change-Id: I1f18aad0341ef5129bc5504e9419a3c422d8bdfd
Reviewed-on: https://chromium-review.googlesource.com/478551
Commit-Ready: Dylan Reid <dgreid@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'kvm/Cargo.toml')
-rw-r--r--kvm/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/kvm/Cargo.toml b/kvm/Cargo.toml
new file mode 100644
index 0000000..11afad4
--- /dev/null
+++ b/kvm/Cargo.toml
@@ -0,0 +1,9 @@
+[package]
+name = "kvm"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[dependencies]
+libc = "*"
+kvm_sys = { path = "../kvm_sys" }
+sys_util = { path = "../sys_util" }