summary refs log tree commit diff
path: root/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2019-03-13 14:21:44 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-03-25 17:43:51 -0700
commit3a42190cc40bc910d402b6207b26f2b4081d200a (patch)
tree8d6e9d98bf22aed7ec904a63ec1ab04a669229da /fuzz/Cargo.toml
parentdb4721d8709a7d139f9b6cb405b22e2a405072ff (diff)
downloadcrosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar.gz
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar.bz2
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar.lz
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar.xz
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.tar.zst
crosvm-3a42190cc40bc910d402b6207b26f2b4081d200a.zip
fuzz: update to use new cros fuzzing
There is now infrastructure for running fuzzers in cros, use it.

Change-Id: I53ec9e195b7062fdcc38b5186c1f3194031037f3
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/1521667
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Chirantan Ekbote <chirantan@chromium.org>
Diffstat (limited to 'fuzz/Cargo.toml')
-rw-r--r--fuzz/Cargo.toml16
1 files changed, 4 insertions, 12 deletions
diff --git a/fuzz/Cargo.toml b/fuzz/Cargo.toml
index 91c4bcb..3b09eb6 100644
--- a/fuzz/Cargo.toml
+++ b/fuzz/Cargo.toml
@@ -1,19 +1,11 @@
 [package]
 name = "crosvm-fuzz"
 version = "0.0.1"
-authors = ["Automatically generated"]
-publish = false
-
-[package.metadata]
-cargo-fuzz = true
-
-[dependencies.kernel_loader]
-path = "../kernel_loader"
-[dependencies.libfuzzer-sys]
-git = "https://github.com/rust-fuzz/libfuzzer-sys.git"
+authors = ["The Chromium OS Authors"]
 
 [dependencies]
 libc = "*"
+kernel_loader = { path = "../kernel_loader" }
 sys_util = { path = "../sys_util" }
 
 # Prevent this from interfering with workspaces
@@ -21,5 +13,5 @@ sys_util = { path = "../sys_util" }
 members = ["."]
 
 [[bin]]
-name = "fuzz_zimage"
-path = "fuzzers/fuzz_zimage.rs"
+name = "crosvm_zimage_fuzzer"
+path = "zimage_fuzzer.rs"