summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2017-10-13 13:18:00 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-10-25 05:52:43 -0700
commitb3bfbde1db2fb19ccb79a9da738108286d91f556 (patch)
tree827db5a5b76bc7d1eb7d513ba9c665b2f2e065a3 /devices/Cargo.toml
parentd37aa9fab5dfa79e2859d86debd02ed11da932c9 (diff)
downloadcrosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar.gz
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar.bz2
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar.lz
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar.xz
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.tar.zst
crosvm-b3bfbde1db2fb19ccb79a9da738108286d91f556.zip
Use minijail_fork
Using minijail_fork removes the need to manage user and pid namespace
explicitly in crosvm and removes some parent/child synchonization
requirements too.

Change-Id: I47f9d39527d0a3ccf625600e9bfc2cccc3cb27ca
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/719443
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index 1c1eeb9..54b9487 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -7,6 +7,7 @@ authors = ["The Chromium OS Authors"]
 byteorder = "*"
 data_model = { path = "../data_model" }
 libc = "*"
+io_jail = { path = "../io_jail" }
 net_sys = { path = "../net_sys" }
 net_util = { path = "../net_util" }
 sys_util = { path = "../sys_util" }