summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-04-05 20:34:50 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-12 14:49:57 -0700
commit65928af6c9ebf46abcd4fbd908fc76137e9843cd (patch)
tree5aaacc0e15f10031d09de71dd81c6b5c1e254a81 /devices/Cargo.toml
parent1aca8b72694fcbefc4f31bf49f41e7491ad29db4 (diff)
downloadcrosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar.gz
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar.bz2
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar.lz
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar.xz
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.tar.zst
crosvm-65928af6c9ebf46abcd4fbd908fc76137e9843cd.zip
protos: Merge plugin_proto crate under protos::plugin
This de-duplicates the two separate build.rs files dealing with proto
compilation. The trunks interface.proto will be exposed under
protos::trunks and the plugin proto will be exposed under protos::plugin.

BUG=none
TEST=cargo check
TEST=cargo check --features tpm
TEST=cargo check --features plugin
TEST=cargo check --features tpm,plugin
TEST=FEATURES=test emerge-nami crosvm
TEST=FEATURES=test USE=crosvm-tpm emerge-nami crosvm
TEST=FEATURES=test USE=crosvm-plugin emerge-nami crosvm
TEST=FEATURES=test USE='crosvm-tpm crosvm-plugin' emerge-nami crosvm
TEST=local kokoro
CQ-DEPEND=CL:1553971

Change-Id: I203b654a38e9d671a508156ae06dfb6f70047c4f
Reviewed-on: https://chromium-review.googlesource.com/1556417
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index d916df8..7a09f4a 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -6,7 +6,7 @@ authors = ["The Chromium OS Authors"]
 [features]
 gpu = ["gpu_buffer", "gpu_display", "gpu_renderer"]
 sandboxed-libusb = ["usb_util/sandboxed-libusb"]
-tpm = ["protos", "tpm2"]
+tpm = ["protos/trunks", "tpm2"]
 wl-dmabuf = []
 
 [dependencies]