summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-05-03 16:58:27 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-07-20 05:30:54 -0700
commitf40bb190ece97c908f8dba2efc7c1aceb4fc0e0b (patch)
tree639ee95c303bc0e9abc79508aa0b0d30843739f3 /Cargo.toml
parent86fdb1dc50c62682ee20794a922be402bbe748a5 (diff)
downloadcrosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar.gz
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar.bz2
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar.lz
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar.xz
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.tar.zst
crosvm-f40bb190ece97c908f8dba2efc7c1aceb4fc0e0b.zip
gpu_renderer: add virglrenderer bindings
These bindings are needed for virtio-gpu 3D capabilities.

All the rust files under gpu_renderer/src/generated are generated via
the gpu_renderer/src/generated/generate script.

The gpu_renderer/src/lib.rs file contains the Renderer and Context
structs, which are the main interfaces to virglrenderer. They
encapsulate the global state of virglrenderer (Renderer) and each
context ID (Context).

The command_buffer module is included only for basic testing and is not
intended for production use.

The pipe_format_fourcc module is provided for the conversion of
virglrenderer specifc formats to standard fourcc formats.

BUG=chromium:837073
TEST=cargo build -p gpu_renderer
CQ-DEPEND=CL:1144406

Change-Id: Iad153390f618309bf493e92e76432c0b1c4a8a93
Reviewed-on: https://chromium-review.googlesource.com/1043447
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43a73bd..69d21e0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,7 @@ arch = { path = "arch" }
 devices = { path = "devices" }
 gpu_buffer = { path = "gpu_buffer", optional = true }
 gpu_display = { path = "gpu_display", optional = true }
+gpu_renderer = { path = "gpu_renderer", optional = true }
 io_jail = { path = "io_jail" }
 kvm = { path = "kvm" }
 kvm_sys = { path = "kvm_sys" }