summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Verkamp <dverkamp@chromium.org>2019-12-17 17:04:58 -0800
committerCommit Bot <commit-bot@chromium.org>2020-01-06 21:26:38 +0000
commitf2eecc4152eca8d395566cffa2c102ec090a152d (patch)
tree9480039e894cdfc3eb47e7953d225d47323981d5 /Cargo.toml
parent521cf5d6d3faad12671ba0f7eb5d6ed85fc20693 (diff)
downloadcrosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar.gz
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar.bz2
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar.lz
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar.xz
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.tar.zst
crosvm-f2eecc4152eca8d395566cffa2c102ec090a152d.zip
disk: move qcow into disk crate
Move qcow from being its own crate into a module of the disk crate,
similar to the composite disk module.

This will allow use of qcow from disk and vice versa without introducing
a circular crate dependency.

BUG=None
TEST=./build_test.py
TEST=USE='asan fuzzer' emerge-nami crosvm

Change-Id: I77512bbe4b94faff1b5460f9796ee56505135580
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/crosvm/+/1972477
Reviewed-by: Cody Schuffelen <schuffelen@google.com>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Commit-Queue: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 69d1a42..231e532 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -61,7 +61,6 @@ net_util = { path = "net_util" }
 p9 = { path = "p9" }
 protobuf = { version = "2.3", optional = true }
 protos = { path = "protos", optional = true }
-qcow = { path = "qcow" }
 rand_ish = { path = "rand_ish" }
 remain = "*"
 resources = { path = "resources" }