summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2019-03-13 17:02:32 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-03-17 21:33:08 -0700
commita6b9ca338879b502b33ec48ca82ec60dcaa170f9 (patch)
treeab27a3f5089542e76a1ddda8a689ce6655ca617a /Cargo.toml
parent100e6e48ad292406fb6f0a7eeb85465850bc28c7 (diff)
downloadcrosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar.gz
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar.bz2
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar.lz
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar.xz
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.tar.zst
crosvm-a6b9ca338879b502b33ec48ca82ec60dcaa170f9.zip
usb: remove unused usb-emulation feature flag
This cleans up some feature flag plumping for libusb sandboxing as well.

BUG=chromium:831850
TEST=cargo test
CQ-DEPEND=CL:1512762

Change-Id: Ic70784db204ddced94498944b021bcb7dd708bb1
Reviewed-on: https://chromium-review.googlesource.com/1522214
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: Jingkui Wang <jkwang@google.com>
Reviewed-by: Jingkui Wang <jkwang@google.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 1 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ed06b35..23fce21 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,10 +24,9 @@ plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 default-no-sandbox = []
 wl-dmabuf = ["devices/wl-dmabuf", "gpu_buffer", "resources/wl-dmabuf"]
 gpu = ["devices/gpu"]
-usb-emulation = ["usb_util"]
 tpm = ["devices/tpm"]
 gpu-forward = ["render_node_forward"]
-sandboxed-libusb = ["devices/sandboxed-libusb", "usb_util/sandboxed-libusb", "vm_control/sandboxed-libusb"]
+sandboxed-libusb = ["devices/sandboxed-libusb", "vm_control/sandboxed-libusb"]
 
 [dependencies]
 arch = { path = "arch" }
@@ -41,7 +40,6 @@ kvm = { path = "kvm" }
 kvm_sys = { path = "kvm_sys" }
 msg_socket = { path = "msg_socket" }
 sys_util = "*"
-usb_util = { path = "usb_util", optional = true }
 kernel_cmdline = { path = "kernel_cmdline" }
 kernel_loader = { path = "kernel_loader" }
 libc = "=0.2.44"