summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-01-31 12:54:51 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-02-12 22:42:35 -0800
commit53528e33eda615ef309915447b227d2dcacb2090 (patch)
tree3a6e80a92de761df09a96ad0596b7982d8f463aa /Cargo.toml
parentbb678718926888701eb17f1ba1c5721592d7f881 (diff)
downloadcrosvm-53528e33eda615ef309915447b227d2dcacb2090.tar
crosvm-53528e33eda615ef309915447b227d2dcacb2090.tar.gz
crosvm-53528e33eda615ef309915447b227d2dcacb2090.tar.bz2
crosvm-53528e33eda615ef309915447b227d2dcacb2090.tar.lz
crosvm-53528e33eda615ef309915447b227d2dcacb2090.tar.xz
crosvm-53528e33eda615ef309915447b227d2dcacb2090.tar.zst
crosvm-53528e33eda615ef309915447b227d2dcacb2090.zip
add support for accessing debug registers in the plugin process
The debug registers are useful to access for the plugin process in some
cases.

TEST=cargo test --features plugin; cargo test -p kvm; ./build_test
BUG=chromium:800626

Change-Id: I8f3f6c31c6989061a43cef948cf5b4e64bd52d30
Reviewed-on: https://chromium-review.googlesource.com/896945
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3f63e6e..d00c58a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -37,3 +37,4 @@ x86_64 = { path = "x86_64" }
 
 [dev-dependencies]
 rand = "=0.3.20"
+sys_util = { path = "sys_util" }