summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-04-06 14:30:04 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-09 01:55:14 -0700
commit48ff4165d273d929349b8f38169ab6dd8ba2be74 (patch)
tree10e51321e3ff825b9aa20dac398936f64d9a6caa /Cargo.toml
parent59bb7129924b4347f42a1661e81ce6c45a442726 (diff)
downloadcrosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar.gz
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar.bz2
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar.lz
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar.xz
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.tar.zst
crosvm-48ff4165d273d929349b8f38169ab6dd8ba2be74.zip
cargo: Sort all dependency lists in Cargo.toml
This may help reduce cases of conflicts between independent CLs each
appending a dependency at the bottom of the list, of which I hit two
today rebasing some of my open CLs.

TEST=cargo check --all-features

Change-Id: Ief10bb004cc7b44b107dc3841ce36c6b23632aed
Reviewed-on: https://chromium-review.googlesource.com/1557172
Commit-Ready: David Tolnay <dtolnay@chromium.org>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml34
1 files changed, 17 insertions, 17 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7343025..4a6edc5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,52 +13,52 @@ members = ["qcow_utils"]
 exclude = [
     "assertions",
     "data_model",
+    "rand_ish",
     "sync",
     "sys_util",
     "syscall_defines",
     "tempdir",
-    "rand_ish",
 ]
 
 [features]
-plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 default-no-sandbox = []
-wl-dmabuf = ["devices/wl-dmabuf", "gpu_buffer", "resources/wl-dmabuf"]
 gpu = ["devices/gpu"]
-tpm = ["devices/tpm"]
 gpu-forward = ["render_node_forward"]
+plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 sandboxed-libusb = ["devices/sandboxed-libusb", "vm_control/sandboxed-libusb"]
+tpm = ["devices/tpm"]
+wl-dmabuf = ["devices/wl-dmabuf", "gpu_buffer", "resources/wl-dmabuf"]
 
 [dependencies]
 arch = { path = "arch" }
 audio_streams = "*"
 bit_field = { path = "bit_field" }
+byteorder = "=1.1.0"
+crosvm_plugin = { path = "crosvm_plugin", optional = true }
+data_model = "*"
 devices = { path = "devices" }
 enumn = { path = "enumn" }
 gpu_buffer = { path = "gpu_buffer", optional = true }
 io_jail = { path = "io_jail" }
-kvm = { path = "kvm" }
-kvm_sys = { path = "kvm_sys" }
-msg_socket = { path = "msg_socket" }
-sys_util = "*"
 kernel_cmdline = { path = "kernel_cmdline" }
 kernel_loader = { path = "kernel_loader" }
+kvm = { path = "kvm" }
+kvm_sys = { path = "kvm_sys" }
 libc = "=0.2.44"
 libcras = "*"
-byteorder = "=1.1.0"
+msg_socket = { path = "msg_socket" }
 net_util = { path = "net_util" }
-vhost = { path = "vhost" }
-vm_control = { path = "vm_control" }
-data_model = "*"
-qcow = { path = "qcow" }
+p9 = { path = "p9" }
 plugin_proto = { path = "plugin_proto", optional = true }
-crosvm_plugin = { path = "crosvm_plugin", optional = true }
 protobuf = { version = "=1.4.3", optional = true }
-resources = { path = "resources" }
-p9 = { path = "p9" }
-sync = { path = "sync" }
+qcow = { path = "qcow" }
 rand_ish = { path = "rand_ish" }
 render_node_forward = { path = "render_node_forward", optional = true }
+resources = { path = "resources" }
+sync = { path = "sync" }
+sys_util = "*"
+vhost = { path = "vhost" }
+vm_control = { path = "vm_control" }
 
 [target.'cfg(target_arch = "x86_64")'.dependencies]
 x86_64 = { path = "x86_64" }