summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2018-12-03 23:37:46 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-12-05 01:13:41 -0800
commit1d4d44a8e229d63aa16d05615ed33100f949863e (patch)
tree773bb9b2e6eb29b64d0d68e4985c6e2daf3bb7cc /Cargo.toml
parent2ea8f3d0aa7230da41b3e6beba27ff9140f661d3 (diff)
downloadcrosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar.gz
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar.bz2
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar.lz
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar.xz
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.tar.zst
crosvm-1d4d44a8e229d63aa16d05615ed33100f949863e.zip
sync: Mutex type with methods that panic instead of return error
This CL adds a crate `sync` containing a type sync::Mutex which wraps
the standard library Mutex and mirrors the same methods, except that
they panic where the standard library would return a PoisonError. This
API codifies our error handling strategy around poisoned mutexes in
crosvm.

- Crosvm releases are built with panic=abort so poisoning never occurs.
  A panic while a mutex is held (or ever) takes down the entire process.
  Thus we would like for code not to have to consider the possibility of
  poison.

- We could ask developers to always write `.lock().unwrap()` on a
  standard library mutex. However, we would like to stigmatize the use
  of unwrap. It is confusing to permit unwrap but only on mutex lock
  results. During code review it may not always be obvious whether a
  particular unwrap is unwrapping a mutex lock result or a different
  error that should be handled in a more principled way.

Developers should feel free to use sync::Mutex anywhere in crosvm that
they would otherwise be using std::sync::Mutex.

TEST=boot linux

Change-Id: I9727b6f8fee439edb4a8d52cf19d59acf04d990f
Reviewed-on: https://chromium-review.googlesource.com/1359923
Commit-Ready: David Tolnay <dtolnay@chromium.org>
Tested-by: David Tolnay <dtolnay@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 90f9dc5..912f9c6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -44,6 +44,7 @@ protobuf = { version = "=1.4.3", optional = true }
 resources = { path = "resources" }
 p9 = { path = "p9" }
 rand = "=0.3.20"
+sync = { path = "sync" }
 
 [target.'cfg(target_arch = "x86_64")'.dependencies]
 x86_64 = { path = "x86_64" }