summary refs log tree commit diff
path: root/release.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/release.nix b/release.nix
index 15471d0..707c86c 100644
--- a/release.nix
+++ b/release.nix
@@ -3,16 +3,16 @@
 
 # This file is built to populate the binary cache.
 
-# Set config = {} to disable implicitly reading config.nix, since
-# we'll want the result to be the same as on the binary cache.  If it
-# turns out there is a compelling reason to read the default config
-# here, we can reconsider this.
-{ config ? import nix/eval-config.nix { config = {}; } }:
-
-{
+import nix/eval-config.nix ({ config, ... }: {
   doc = import ./Documentation { inherit config; };
 
   checks = import nix/checks.nix { inherit config; };
 
   combined = import release/combined/run-vm.nix { inherit config; };
-}
+})
+
+# Set config = {} to disable implicitly reading config.nix, since
+# we'll want the result to be the same as on the binary cache.  If it
+# turns out there is a compelling reason to read the default config
+# here, we can reconsider this.
+{ config = {}; }