summary refs log tree commit diff
path: root/img/app/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'img/app/shell.nix')
-rw-r--r--img/app/shell.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/img/app/shell.nix b/img/app/shell.nix
index 83dcd76..7a323aa 100644
--- a/img/app/shell.nix
+++ b/img/app/shell.nix
@@ -1,9 +1,8 @@
 # SPDX-License-Identifier: MIT
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
 
-{ config ? import ../../nix/eval-config.nix {}
-, run ? ../../vm/app/catgirl.nix
-}:
+import ../../nix/eval-config.nix (
+{ config, run ? ../../vm/app/catgirl.nix, ... }:
 
 with config.pkgs;
 
@@ -21,4 +20,4 @@ with config.pkgs;
   shellHook = ''
     export RUN_IMG="$(printf "%s\n" "$runDef"/blk/run.img)"
   '';
-})
+}))