summary refs log tree commit diff
path: root/host/rootfs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/rootfs/default.nix')
-rw-r--r--host/rootfs/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/host/rootfs/default.nix b/host/rootfs/default.nix
index ad997d1..acc0719 100644
--- a/host/rootfs/default.nix
+++ b/host/rootfs/default.nix
@@ -2,7 +2,8 @@
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
 # SPDX-FileCopyrightText: 2022 Unikie
 
-{ config ? import ../../nix/eval-config.nix {} }: let inherit (config) pkgs; in
+import ../../nix/eval-config.nix (
+{ config, src, ... }: let inherit (config) pkgs; in
 pkgs.pkgsStatic.callPackage (
 
 { lib, stdenvNoCC, nixos, runCommand, writeReferencesToFile, s6-rc, tar2ext4
@@ -120,7 +121,7 @@ in
 stdenvNoCC.mkDerivation {
   name = "spectrum-rootfs";
 
-  inherit (config) src;
+  inherit src;
   sourceRoot = "source/host/rootfs";
 
   nativeBuildInputs = [ s6-rc tar2ext4 ];
@@ -142,4 +143,4 @@ stdenvNoCC.mkDerivation {
     platforms = platforms.linux;
   };
 }
-) {}
+) {})