summary refs log tree commit diff
path: root/msg_socket2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'msg_socket2/Cargo.toml')
-rw-r--r--msg_socket2/Cargo.toml9
1 files changed, 8 insertions, 1 deletions
diff --git a/msg_socket2/Cargo.toml b/msg_socket2/Cargo.toml
index 7a7cf73..1662ab3 100644
--- a/msg_socket2/Cargo.toml
+++ b/msg_socket2/Cargo.toml
@@ -1,12 +1,19 @@
+# SPDX-License-Identifier: MIT OR Apache-2.0
+# Copyright 2020, Alyssa Ross
+
 [package]
 name = "msg_socket2"
 version = "0.1.0"
 authors = ["Alyssa Ross <hi@alyssa.is>"]
+license = "MIT OR Apache-2.0"
 edition = "2018"
+description = "Send messages over Unix domain sockets, including file descriptors"
+readme = "README"
 
 [dependencies]
+libc = "*"
 msg_socket2_derive = { path = "derive" }
-serde = "1.0.104"
+serde = { version = "1.0.104" }
 sys_util = { path = "../sys_util" }
 
 bincode = { git = "https://github.com/alyssais/bincode", branch = "from_slice" }