summary refs log tree commit diff
path: root/x86_64/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Verkamp <dverkamp@chromium.org>2018-09-24 15:00:36 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-10-02 09:17:25 -0700
commitd635acbaf348c0863bc05b8f889b2fa5f8156aaa (patch)
tree02319a17d31193be6f28663570cab51ec7be2f9f /x86_64/Cargo.toml
parenta158e310380bfcbb63fa5015d01c58fc0f0731da (diff)
downloadcrosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar.gz
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar.bz2
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar.lz
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar.xz
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.tar.zst
crosvm-d635acbaf348c0863bc05b8f889b2fa5f8156aaa.zip
linux: Convert all virtio devices to PCI
Change the main create_virtio_devs() function to create virtio devices
using the PCI transport rather than MMIO.

BUG=chromium:854766
TEST=Boot crosvm and verify that all virtio devices still work

Change-Id: I9a6e60b21edea1e5ac2b3ae5c91793d45cf5063a
Signed-off-by: Daniel Verkamp <dverkamp@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/1241541
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'x86_64/Cargo.toml')
-rw-r--r--x86_64/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/x86_64/Cargo.toml b/x86_64/Cargo.toml
index d814814..687dec9 100644
--- a/x86_64/Cargo.toml
+++ b/x86_64/Cargo.toml
@@ -8,6 +8,7 @@ build = "build.rs"
 arch = { path = "../arch" }
 data_model = { path = "../data_model" }
 devices = { path = "../devices" }
+io_jail = { path = "../io_jail" }
 kvm_sys = { path = "../kvm_sys" }
 kvm = { path = "../kvm" }
 sys_util = { path = "../sys_util" }