summary refs log tree commit diff
path: root/vhost_rs/Cargo.toml
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2020-08-11 10:49:38 +0000
committerAlyssa Ross <hi@alyssa.is>2021-05-11 12:19:50 +0000
commitfe5750a3854c98635755cd9d0ceb05de896c0e67 (patch)
tree28955f2094e0903a268e4f99eb684d27f1d521fe /vhost_rs/Cargo.toml
parent8a7e4e902a4950b060ea23b40c0dfce7bfa1b2cb (diff)
downloadcrosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar.gz
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar.bz2
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar.lz
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar.xz
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.tar.zst
crosvm-fe5750a3854c98635755cd9d0ceb05de896c0e67.zip
devices: port vhost-user-net from cloud-hypervisor
This is the cloud-hypervisor vhost-user-net code, modified just enough
to compile as part of crosvm.  There is currently no way to run crosvm
with a vhost-user-net device, and even if there were, it wouldn't work
without some further fixes.
Diffstat (limited to 'vhost_rs/Cargo.toml')
-rw-r--r--vhost_rs/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/vhost_rs/Cargo.toml b/vhost_rs/Cargo.toml
new file mode 100644
index 0000000..0cfbf2c
--- /dev/null
+++ b/vhost_rs/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "vhost_rs"
+version = "0.1.0"
+authors = ["Liu Jiang <gerry@linux.alibaba.com>"]
+repository = "https://github.com/rust-vmm/vhost"
+license = "Apache-2.0 or BSD-3-Clause"
+
+[features]
+default = []
+vhost-vsock = []
+vhost-kern = ["vm-memory"]
+vhost-user-master = []
+vhost-user-slave = []
+
+[dependencies]
+bitflags = "1.1.0"
+libc = "0.2.60"
+sys_util = { path = "../sys_util" }
+vmm-sys-util = { git = "https://github.com/rust-vmm/vmm-sys-util" }
+
+[dependencies.vm-memory]
+git = "https://github.com/rust-vmm/vm-memory"
+optional = true
+
+[dev-dependencies]
+tempfile = "3.1.0"