summary refs log tree commit diff
path: root/usb_sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Verkamp <dverkamp@chromium.org>2019-04-18 14:54:31 -0700
committerCommit Bot <commit-bot@chromium.org>2019-09-09 18:20:41 +0000
commit0b86007d3e1ee400c6201c00b7dea323d661b50f (patch)
tree8ac74406abaae5bc7db4fb3437dd49d5408c308c /usb_sys/Cargo.toml
parent13eea9f02870a05253f86e4fc9ba4e35367950de (diff)
downloadcrosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar.gz
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar.bz2
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar.lz
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar.xz
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.tar.zst
crosvm-0b86007d3e1ee400c6201c00b7dea323d661b50f.zip
Add usb_sys wrapper for usbfs
This wraps the Linux USBDEVFS ioctl interfaces.

BUG=chromium:987833
TEST=./build_test.py

Change-Id: Id855c66c4eb2ac01bb65073b5dd339c1c3d45c38
Signed-off-by: Daniel Verkamp <dverkamp@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/crosvm/+/1783600
Reviewed-by: Zach Reizner <zachr@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Diffstat (limited to 'usb_sys/Cargo.toml')
-rw-r--r--usb_sys/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/usb_sys/Cargo.toml b/usb_sys/Cargo.toml
new file mode 100644
index 0000000..15cc26f
--- /dev/null
+++ b/usb_sys/Cargo.toml
@@ -0,0 +1,8 @@
+[package]
+name = "usb_sys"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+edition = "2018"
+
+[dependencies]
+sys_util = { path = "../sys_util" }