summary refs log tree commit diff
path: root/qcow_utils/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2018-01-18 13:39:51 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-02-01 21:29:31 -0800
commit6ecbbfd72312a07c1b9cd686aa2594f072448d40 (patch)
tree8bbc337835e4cf936fd3b28603d7166bcf2abb4c /qcow_utils/Cargo.toml
parent29cd40a1d61c0d558768e0d32f07f7b7ad84ca63 (diff)
downloadcrosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar.gz
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar.bz2
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar.lz
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar.xz
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.tar.zst
crosvm-6ecbbfd72312a07c1b9cd686aa2594f072448d40.zip
Add qcow_utils for exposing qcow functions as a C library
This C library will be use by the VM launcher to create the qcow2 files
used for persistent VM data.

CQ-DEPEND=CL:884263
BUG=none
TEST=cargo test --all -- --test-threads=1

Change-Id: Ibd7f71d2e3f1f72f781978f014865d2161f033f5
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/875116
Diffstat (limited to 'qcow_utils/Cargo.toml')
-rw-r--r--qcow_utils/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/qcow_utils/Cargo.toml b/qcow_utils/Cargo.toml
new file mode 100644
index 0000000..5ec3343
--- /dev/null
+++ b/qcow_utils/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "qcow_utils"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[lib]
+path = "src/qcow_utils.rs"
+crate-type = ["cdylib"]
+
+[dependencies]
+libc = "*"
+qcow = { path = "../qcow" }