summary refs log tree commit diff
path: root/p9/wire_format_derive/Cargo.toml
diff options
context:
space:
mode:
authorChirantan Ekbote <chirantan@chromium.org>2018-03-19 16:49:53 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-05-22 21:56:58 -0700
commit800fcb060f4412a1e0d0f8802f8419266fe5105f (patch)
tree3e7d2051ca94eb776199af69f9cb2b57dd8e3b10 /p9/wire_format_derive/Cargo.toml
parentd8f10af6aeaff319f407578cdff1afd0324f5912 (diff)
downloadcrosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar.gz
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar.bz2
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar.lz
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar.xz
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.tar.zst
crosvm-800fcb060f4412a1e0d0f8802f8419266fe5105f.zip
Add low-level p9 protocol implementation
Implement encoding and decoding various primitives using the p9
protocol.  In addition, add a procedural macro to derive the encoding
and decoding implementation for structs built out of the primitives.

BUG=chromium:703939
TEST=unit tests
CQ-DEPEND=CL:1065063

Change-Id: I7256633fb7002da9ce8af03be2f24410b90ccf3f
Signed-off-by: Chirantan Ekbote <chirantan@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/969965
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Diffstat (limited to 'p9/wire_format_derive/Cargo.toml')
-rw-r--r--p9/wire_format_derive/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/p9/wire_format_derive/Cargo.toml b/p9/wire_format_derive/Cargo.toml
new file mode 100644
index 0000000..77d41b5
--- /dev/null
+++ b/p9/wire_format_derive/Cargo.toml
@@ -0,0 +1,13 @@
+[package]
+name = "wire_format_derive"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[dependencies]
+syn = "=0.12"
+quote = "=0.4"
+proc-macro2 = "=0.2"
+
+[lib]
+proc-macro = true
+path = "wire_format_derive.rs"