summary refs log tree commit diff
path: root/p9/Cargo.toml
diff options
context:
space:
mode:
authorChirantan Ekbote <chirantan@chromium.org>2018-04-04 18:16:43 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-06-15 10:56:39 -0700
commitb657603f10daf62fa6fe18d56adbe35f6caf8587 (patch)
tree31148a8e1d69f1e8a3c5ed60748498e09e9617a6 /p9/Cargo.toml
parenta7b0a712042dcc60baf88a48d1220633ed4a192f (diff)
downloadcrosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar.gz
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar.bz2
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar.lz
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar.xz
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.tar.zst
crosvm-b657603f10daf62fa6fe18d56adbe35f6caf8587.zip
p9: Add server implementation
Implement all the server methods for the 9P protocol.

BUG=chromium:703939
TEST=bonnie++ -r 256

Change-Id: I6b1b5fe4fea4d4941db42e5c1a364a54d0827054
Signed-off-by: Chirantan Ekbote <chirantan@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/1013203
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'p9/Cargo.toml')
-rw-r--r--p9/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/p9/Cargo.toml b/p9/Cargo.toml
index 674df06..964cd1c 100644
--- a/p9/Cargo.toml
+++ b/p9/Cargo.toml
@@ -4,4 +4,8 @@ version = "0.1.0"
 authors = ["The Chromium OS Authors"]
 
 [dependencies]
+libc = "*"
 wire_format_derive = { path = "wire_format_derive" }
+
+[features]
+trace = []
\ No newline at end of file