summary refs log tree commit diff
path: root/gpu_display/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-05-03 13:19:37 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-07-09 15:48:21 -0700
commit20d71f8928e1e95f6554c87cfca12f24f9f652cf (patch)
tree1d383fdbe0edf037f55b5b0f0100ee8a2fd94747 /gpu_display/Cargo.toml
parentac5a8dbe505daf95a802cc606988bc2323087a05 (diff)
downloadcrosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar.gz
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar.bz2
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar.lz
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar.xz
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.tar.zst
crosvm-20d71f8928e1e95f6554c87cfca12f24f9f652cf.zip
gpu_display: provides wayland based output for virtio-gpu
This provides virtual display style output, useful for debugging
virtio-gpu. Although using virtio-gpu for display purposes clashes with
the more integreated virtio-wayland support, it is nonetheless helpful
for debugging virtio-gpu, and is technically required to fully implement
that device.

TEST=cargo build -p gpu_display
BUG=chromium:837073
CQ-DEPEND=CL:1096300

Change-Id: I59f895e951ef593d4119e7558168dd34223519ee
Reviewed-on: https://chromium-review.googlesource.com/1043446
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'gpu_display/Cargo.toml')
-rw-r--r--gpu_display/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/gpu_display/Cargo.toml b/gpu_display/Cargo.toml
new file mode 100644
index 0000000..fbd16ff
--- /dev/null
+++ b/gpu_display/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "gpu_display"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+
+[dependencies]
+data_model = { path = "../data_model" }
+libc = "*"
+sys_util = { path = "../sys_util" }
+
+[build-dependencies]
+cc = "=1.0.15"